GlassCutter

  • Karma: +31/-0
Re: About installing my new sound system?
« Reply #25 on: December 27, 2010, 03:36:28 PM »
When picking up skiers in my 18ft Horizon, I cannot count how many times we took a wave over the bow and right into our laps.   That boat sat real close to the water and  the slow turnaround and approach to a downed skier had us often headed directly to a big swell.  If you weren't paying attention and ready with a quick blip of throttle you would get seriously soaked.   Just something to keep in mind . . .
  • Boat #1: 1973  Wriedt Montara 23
  • Boat #2: 1978 Spectra 20 460/Berkley
  • Like
    Dislike
    Love
    HaHa
    Angry
    Surprise
    Sad
    Party
Also, I will kiss bare male ass in the middle of the Vegas Strip  . . .  I will post pics if I need to.  --  IRRebel 2013

"Go ahead Rivertard does it.  Take a video though."

"If you did it in a dodge it would have shifted perfectly ran a thousand miles per hour and got optimum fuel mileage!"  Nordie  2012

Nordie

  • Karma: +13/-0
Re: Re: About installing my new sound system?
« Reply #26 on: December 27, 2010, 03:47:40 PM »
This is all i did...i didnt have a bulkhead so i made this



Followed by this



Pow mounted....only took a couple hours



I put the cover on it because my feet go down there and didnt want to hit the deck with my feet...also it had a remote so i dont half to reach down there
  • Like
    Dislike
    Love
    HaHa
    Angry
    Surprise
    Sad
    Party


If im not posting..I'm pooping!

NORDIC454

  • Karma: +2/-0
Re: About installing my new sound system?
« Reply #27 on: January 18, 2011, 04:25:00 PM »
I'm my 20' cruiser I have a 1200W amp running 1 12" in a ported box mounted to the floor under the bow facing the seats. I have 4 6x9's and 2 5x7's in the back. My speakers run off of my head unit which is plenty loud. For the time being, I only have one battery. As long as I monitor my volt gauge, I am fine to start it up after enjoying some tunes for a bit. A 2nd battery is in the near future, and very much needed for high power
  • Boat #1: '03 Cheetah FasCat
  • Like
    Dislike
    Love
    HaHa
    Angry
    Surprise
    Sad
    Party

halfdome

  • Karma: +0/-0
Re: About installing my new sound system?
« Reply #28 on: January 21, 2011, 03:45:55 PM »
Yea, with everyone agreeing that two batteries are nice, if not totally required, I've decided to upgrade. As promised, I've been taking photos of every step in this install. There may be as many as 20 or so by the time I'm done. Is that too many to be placing on this site?  Is there a way to attach a link or something, like the youTube videos people post. I am currently saving them on my facebook page. Thanks again for the continues ideas.
  • Like
    Dislike
    Love
    HaHa
    Angry
    Surprise
    Sad
    Party

Your Mom

  • Karma: +20/-0
Re: About installing my new sound system?
« Reply #29 on: January 21, 2011, 06:30:22 PM »
http://gickr.com/
You can post up to 10 pics for a image show. This will be saved as a single image but will scroll the pics. I use the big size with a nice slideshow.... heres a sample
 


halfdome

  • Karma: +0/-0
Re: About installing my new sound system?
« Reply #30 on: January 23, 2011, 07:19:38 PM »
Well that is truly amazing. I had no idea you had wake-bawd'n pimp cans on that. I decided that's what I wanted to run off my rear amp too. Had no idea what to buy. So I ended up getting Krypts. Mostly cause they claim to be able to take the power I'm throwing at them. I wish I would have known you've already figured that out too :) Obviously on my little 18ft South Wind I can't run a tower; so I plan on mounting them on a couple of short vertical tubes welded to the plates that my battery boxes are attached to (another idea I got from your earlier photos). Maybe I should have just offered to pay you a consulting fee and flown down to see it in person  ;) Thanks again, Alex
  • Like
    Dislike
    Love
    HaHa
    Angry
    Surprise
    Sad
    Party

halfdome

  • Karma: +0/-0
Re: About installing my new sound system?
« Reply #31 on: April 03, 2011, 09:02:10 PM »
The good news is that I finished the install today! Thanks for all the help it turned out great and sounds,,,, well,,, loud! I have tried everything to post the pictures I can't even post 1. Something about the pic being too large or the server too slow. No idea... I'm going to try and upload the pics to one of those picture sites and try referencing the URL. Anyway, thanks again and I'll keep trying on the pics.
  • Like
    Dislike
    Love
    HaHa
    Angry
    Surprise
    Sad
    Party

 


Null

SMFPacks CMS 1.0.3 © 2020