Null


losinging oil pressure

  • 4 Replies
  • 711 Views

Billybob14

  • Join Date: Jul 2017
  • Location: northern cal
  • *
  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
  • Registered User
    • View Profile
  • Liked:
  • Likes Given: 0
« on: July 09, 2017, 01:57:05 PM »
I have a 496 BBC at 5000 rpm I will start to lose oil pressure it goes down to 25 pounds. I have a 10 10qt pan and it is full of oil. at 3000 rpm it stays at 75 psi. I believe I am having a pickup problem. any suggestions on what it cld be ? also when I am at 5000 rpm for like 3 seconds then it starts losing oil pressure. Motor just staring doing this on the 4th. Motor has only 1 hour on it.
« Last Edit: July 09, 2017, 02:06:41 PM by Billybob14 »



BoatsNhoes

  • Join Date: Nov 2014
  • Location: Pomona,ca
  • *
  • Sr. Member
  • ****
  • Posts: 452
  • Karma: +12/-0
  • Registered User
    • View Profile
  • Liked:
  • Likes Given: 0
« Reply #1 on: July 10, 2017, 07:39:41 AM »
Sounds like your oil pump is loosing its prime , when the pick up tube is removed during rebuild the  o ring needs to be replaced . As you re install the tube coat o ring with fresh oil and press tube up into block until you seat it or it clicks and then you have it properly installed . Re install any remaining hard ware and should be good to go .


Sent from my iPhone using SoCal Jet Boats

Blue2184

  • Join Date: Jul 2012
  • Location: Texas
  • *
  • Sr. Member
  • ****
  • Posts: 294
  • Karma: +4/-0
  • Registered User
    • View Profile
  • Liked:
  • Likes Given: 0
« Reply #2 on: July 10, 2017, 12:51:00 PM »
I don't think their is any o-ring on that pick up set up? Just a "kinda" press fit... you might be running to much oil and foaming the oil with your crank? Might try pulling a quart out and see how it does?


Sent from my iPhone using Tapatalk

bahner80

  • Join Date: Nov 2015
  • Location: Menifee
  • *
  • Sr. Member
  • ****
  • Posts: 310
  • Karma: +5/-0
  • Registered User
    • View Profile
  • Liked:
  • Likes Given: 0
« Reply #3 on: July 11, 2017, 09:40:15 AM »
I run 8qts. On my 10 qt. Pan never had oil psi drop below 40#

gbborn

  • Join Date: Jan 2015
  • *
  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
  • Registered User
    • View Profile
  • Liked:
  • Likes Given: 0
« Reply #4 on: July 11, 2017, 09:48:10 AM »
Same thing happened to me pick up tube fell off and was floating around in    The bottom of pan


Sent from my iPhone using SoCal Jet Boats

 


Powered by EzPortal