SoCal Jet Boats

Tech Talk => Engine Mechanical / Electrical => Topic started by: norwegen jet on June 07, 2016, 08:57:17 AM

Title: bad buy
Post by: norwegen jet on June 07, 2016, 08:57:17 AM
Took my first trip on the sea last night.I have mounted a new DISTRIBUTOR from Vegas Rod Parts.I GOT 5 MINUTTS BEFOR THIS HAPPEND.
Title: Re: bad buy
Post by: norwegen jet on June 07, 2016, 09:00:32 AM
This
happened

Sent from my iPhone using SoCal Jet Boats
Title: Re: bad buy
Post by: GT Jets on June 07, 2016, 09:12:39 AM
Does your oil pump turn ok?
Title: Re: bad buy
Post by: norwegen jet on June 07, 2016, 09:15:58 AM
i think so.any way to check this.?
Title: Re: bad buy
Post by: GT Jets on June 07, 2016, 09:21:52 AM
i think so.any way to check this.?

You should be able to turn it very easily with a socket on an extension,  be sure to tape the socket on the end of the extension so you don't drop it in the motor accidentally. Should turn very easily in both directions.

GT
Title: Re: bad buy
Post by: norwegen jet on June 07, 2016, 10:02:29 AM
The oil pump turn good.😎Thanks GT


Sent from my iPhone using SoCal Jet Boats
Title: Re: bad buy
Post by: LakesOnly on June 07, 2016, 10:38:26 AM
Took my first trip on the sea last night.I have mounted a new DISTRIBUTOR from Vegas Rod Parts.I GOT 5 MINUTTS BEFOR THIS HAPPEND.
It appears as though you sheared your distributor roll pin.  That is what is supposed to happen under certain circumstances.  Did you take the time to set your thrust clearance before installing the distributor? Or did you just remove it from the box and install it into your engine?  If you did the latter, then I don't know yet that it is the fault of the parts seller or component manufacturer.

Title: Re: bad buy
Post by: norwegen jet on June 09, 2016, 09:04:27 AM
It appears as though you sheared your distributor roll pin.  That is what is supposed to happen under certain circumstances.  Did you take the time to set your thrust clearance before installing the distributor? Or did you just remove it from the box and install it into your engine?  If you did the latter, then I don't know yet that it is the fault of the parts seller or component manufacturer.

I take the time to set the thrust clearence.so i know this was ok.i email the seller today....