Oil pressure gauge

  • 13 Replies
  • 926 Views

76spectra18

  • Join Date: Apr 2015
  • Location: corona ca
  • *
  • Newbie
  • *
  • Posts: 15
  • Karma: +0/-0
  • Registered User
    • View Profile
  • Liked:
  • Likes Given: 0
« on: August 24, 2019, 07:23:21 PM »
My oil pressure gauge has been pegged at 80 psi. I put a new oil sender in and its still pegged at 80. When i disconnect the wire from the sender it drops to 0, but as soon as i reconnect or ground the wire it pegs out. What else should i look for?


Null


GT Jets

  • Join Date: Jan 2007
  • Location: Morgan Hill CA
  • *
  • Informative Member
  • *******
  • Posts: 11,752
  • Karma: +192/-0
  • Team Evil Weiner
    • View Profile
  • Liked:
  • Likes Given: 138
« Reply #1 on: August 25, 2019, 05:34:12 PM »
What gauge and what does the sender look like?

Sent from my LG-H872 using SoCal Jet Boats mobile app

  • Boat #1: 1992 Carrera 20.5 Elite (I/O bitches)
  • Boat #2: 19' Bubble deck Jet BBC Berkeley
If i get some free time tonight at work, ill play with it and post it for everyone to see.

Time to man up and yank it John!  :banghead:
Ray

perryb

  • Join Date: Jul 2019
  • Location: Chico, CA
  • *
  • Newbie
  • *
  • Posts: 22
  • Karma: +3/-0
  • Registered User
    • View Profile
  • Liked:
  • Likes Given: 1
« Reply #2 on: August 25, 2019, 06:57:31 PM »
Somewhere between the gauge and sender, that wire is shorted directly to ground.

76spectra18

  • Join Date: Apr 2015
  • Location: corona ca
  • *
  • Newbie
  • *
  • Posts: 15
  • Karma: +0/-0
  • Registered User
    • View Profile
  • Liked:
  • Likes Given: 0
« Reply #3 on: August 25, 2019, 07:40:27 PM »
Its a faria gauge

76spectra18

  • Join Date: Apr 2015
  • Location: corona ca
  • *
  • Newbie
  • *
  • Posts: 15
  • Karma: +0/-0
  • Registered User
    • View Profile
  • Liked:
  • Likes Given: 0
« Reply #4 on: August 25, 2019, 07:43:31 PM »
If its a short between the gauge and sender what exactly does that mean? A broken wire? I hate electrical  :banghead:

GT Jets

  • Join Date: Jan 2007
  • Location: Morgan Hill CA
  • *
  • Informative Member
  • *******
  • Posts: 11,752
  • Karma: +192/-0
  • Team Evil Weiner
    • View Profile
  • Liked:
  • Likes Given: 138
« Reply #5 on: August 25, 2019, 10:02:44 PM »
If its a short between the gauge and sender what exactly does that mean? A broken wire? I hate electrical  :banghead:
Grab a length of wire and run it from the sender to the gauge bypassing the existing wire.

Sounds like the existing wire is pinched or shorted to another wire.

Sent from my LG-H872 using SoCal Jet Boats mobile app

  • Boat #1: 1992 Carrera 20.5 Elite (I/O bitches)
  • Boat #2: 19' Bubble deck Jet BBC Berkeley
If i get some free time tonight at work, ill play with it and post it for everyone to see.

Time to man up and yank it John!  :banghead:
Ray

Tikotiko

  • Join Date: Oct 2018
  • Location: Nuevo
  • *
  • Jr. Member
  • **
  • Posts: 61
  • Karma: +0/-0
  • Registered User
    • View Profile
  • Liked:
  • Likes Given: 7
« Reply #6 on: August 26, 2019, 06:17:20 AM »
Mine does the same and everyone has told me its normal but i havent bypassed the old wire. Probably going to try that today

Sent from my SM-G975U using SoCal Jet Boats mobile app


76spectra18

  • Join Date: Apr 2015
  • Location: corona ca
  • *
  • Newbie
  • *
  • Posts: 15
  • Karma: +0/-0
  • Registered User
    • View Profile
  • Liked:
  • Likes Given: 0
« Reply #7 on: August 26, 2019, 09:05:08 AM »
Ok ill try that. Thanks for the advice

76spectra18

  • Join Date: Apr 2015
  • Location: corona ca
  • *
  • Newbie
  • *
  • Posts: 15
  • Karma: +0/-0
  • Registered User
    • View Profile
  • Liked:
  • Likes Given: 0
« Reply #8 on: September 07, 2019, 07:12:12 PM »
Ok, so i was finally able to test the wire like you said. Disconnected the sender from the gauge and ran a new length of wire straight from the sender to the gauge. As soon as i touch the wire to the sender it still pegs to 80. :banghead: :mad: what the hell esle could it be. Bad gauge? A friend of mine said it the gauge and sender have to be compatible? Any more idea from anyone?

Flusher

  • Join Date: Sep 2011
  • Location: Colton, CA
  • *
  • Macho Member
  • ******
  • Posts: 2,161
  • Karma: +84/-0
  • The Machinist
    • View Profile
  • Liked:
  • Likes Given: 26
« Reply #9 on: September 08, 2019, 11:08:04 PM »
Is this a new problem that recently manifested itself or an existing condition?

Did the gauge ever indicate correctly?

Is this a new engine/oil pump combination?  Do you know if you have a high-volume/high-pressure oil pump?

Does the oil pressure drop when the engine gets to operating temperature?

Do you have a trusted mechanical gauge that you could temporarily install to verify your actual oil pressure?
"I want to roll with my brother Joe" - Joe Bateman - January 29, 1950 ~ November 27, 2013

76spectra18

  • Join Date: Apr 2015
  • Location: corona ca
  • *
  • Newbie
  • *
  • Posts: 15
  • Karma: +0/-0
  • Registered User
    • View Profile
  • Liked:
  • Likes Given: 0
« Reply #10 on: September 09, 2019, 12:38:42 PM »
No it hasn't worked since i bought the boat. I had the motor apart last year and it looks like its all stock 454 chevy.  All the other gauges are working fine. Is it that big a deal to run with no oil gauge.  At least my water temp is good.

Flusher

  • Join Date: Sep 2011
  • Location: Colton, CA
  • *
  • Macho Member
  • ******
  • Posts: 2,161
  • Karma: +84/-0
  • The Machinist
    • View Profile
  • Liked:
  • Likes Given: 26
« Reply #11 on: September 09, 2019, 05:49:41 PM »
In my opinion, the only two important gauges are oil pressure and oil temperature.  Everything else is just ballast..
"I want to roll with my brother Joe" - Joe Bateman - January 29, 1950 ~ November 27, 2013

btnhtillidie

  • Join Date: Sep 2008
  • Location: Los Angeles
  • *
  • Full Member
  • ***
  • Posts: 112
  • Karma: +0/-0
    • View Profile
  • Liked:
  • Likes Given: 0
« Reply #12 on: October 02, 2019, 06:16:17 PM »
Is the 12v switched, piggy backed off another gauge?


Sent from my iPhone using Tapatalk Pro

K-034

  • Join Date: Oct 2012
  • Location: L.H.C
  • *
  • Sr. Member
  • ****
  • Posts: 361
  • Karma: +23/-0
  • Registered User
    • View Profile
  • Liked:
  • Likes Given: 0
« Reply #13 on: October 02, 2019, 07:33:30 PM »
Is the 12v switched, piggy backed off another gauge?


Sent from my iPhone using Tapatalk Pro



Yes. Signal wire works off of a resistance from the ground, if your gauge pegs as soon as the ignition is turned on then the signal wire is grounded out. Thatís also how you test to see if the gauge is good, you just put the signal wire to ground, if it pegs then the gauge works. Water temp, Oil temp, fuel PSI, Oil PSI, etc..... all work the same way if there electronic


Sent from my iPhone using SoCal Jet Boats mobile app
« Last Edit: October 02, 2019, 07:36:00 PM by K-034 »

 


Website Security Test
Powered by EzPortal

Null

anything
Website Security Test