SoCal Jet Boats

Tech Talk => Engine Mechanical / Electrical => Topic started by: $HAG NA$TY on June 07, 2013, 07:46:37 PM

Title: Oil pressure gauge is killing me!
Post by: $HAG NA$TY on June 07, 2013, 07:46:37 PM
Installed my new gauges and all work good but the oil pressure is reading 50 psi when the key is on and motor isn't running. I don't get it. I went over my wiring about 20 times. The sender is the one that came with the gauge in the box.. I'm thinking the gauge or sender is defective:o anyone have any input or have had the same issue? Thanks in advance!

Sent from my LG-VS700 using SoCalJetBoats mobile app

Title: Re: Oil pressure gauge is killing me!
Post by: $HAG NA$TY on June 07, 2013, 07:52:14 PM


Sent from my LG-VS700 using SoCalJetBoats mobile app

Title: Re: Oil pressure gauge is killing me!
Post by: ka0tyk on June 07, 2013, 08:12:37 PM
Take the sender wire from the gaugeand ground it. The gauge should do a full sweep. If it works fine its sender or ground between motor and gauges.
Title: Re: Oil pressure gauge is killing me!
Post by: $HAG NA$TY on June 07, 2013, 09:08:12 PM
Hmm I didn't think of the ground wire. But I do have all the gauges grounded from one wire from the terminal block and series together. I have my power coming off of the hot on the ignition key. If i disconnect the signal it does a full sweep. Idk man its bugging me.

Sent from my LG-VS700 using SoCalJetBoats mobile app

Title: Re: Oil pressure gauge is killing me!
Post by: $HAG NA$TY on June 07, 2013, 09:11:09 PM
Also idk if its the style gauge I have but the tach does a full sweep and back to zero when I turn on the key. Guess I really wont know till I fire it up.. waiting on a fuel pump!>:(

Sent from my LG-VS700 using SoCalJetBoats mobile app

Title: Re: Oil pressure gauge is killing me!
Post by: Xthaspot on June 07, 2013, 11:59:56 PM
I just installed new gauges in my dads boat even after completely rewiring my boat and the gauges were doing funny things like reading 100 psi on the oil psi when on ignition and come to find out I forgot I had tied the ground wire back when I was trying to clean up under the dash and forgot all about it. So definitely make sure you have a solid ground.


Sent from my iPhone using SoCalJetBoats mobile app
Title: Re: Oil pressure gauge is killing me!
Post by: ka0tyk on June 08, 2013, 12:38:02 AM
oops forgot the important part. take the sender wire on the gauge and ground it.  the gauge should move. 
Title: Re: Oil pressure gauge is killing me!
Post by: $HAG NA$TY on June 08, 2013, 12:47:49 AM
Okay. Thanks guys, I appreciate it. Ill give it a shot tomorrow!

Sent from my LG-VS700 using SoCalJetBoats mobile app

Title: Re: Oil pressure gauge is killing me!
Post by: Jet Boat Maloney on September 12, 2013, 01:49:23 AM
Just ran into a weird one while installing my accusump hooked everything up and no pressure reading on the oil pressure  gauge. Then realized they recommended using only plumbers tape on all the fittings. Sitting there pulling my hair out when I realized just how well that tape works as an insulator and found none of my plumbing was grounding. It's amazing what comes to mind when you take a step back and rethink everything!!!


Sent from my iPhone using SoCalJetBoats mobile app