Null


12jc-A-H-ss

  • 9 Replies
  • 4082 Views

12many

  • Join Date: Oct 2010
  • Location: indiana
  • *
  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
  • Liked:
  • Likes Given: 0
« on: October 16, 2010, 10:00:04 AM »
Why does my pump have so many letters on it. I know the 12jc and the A but what is the H for? Is the SS saying it came with a stainless impeller and shaft,because the pump does have both.Boat only runs 3800rpm so i think it has an A impeller.any ideas for the newbie? 455 +60 over olds torker intake eldelbrock 750 carb new comp cams 280 marine cam,


mash on it

  • Join Date: Sep 2008
  • Location: BHC- Beyond Hell Crew & Williams
  • *
  • Macho Member
  • ******
  • Posts: 1,807
  • Karma: +20/-0
  • At the Saloon 'til sun up
    • View Profile
  • Liked:
  • Likes Given: 412
« Reply #1 on: October 16, 2010, 03:37:20 PM »
An Olds should run 46-4800 R's with an "A" impeller, Secondaries working?
Tach right?  No clue what the "H" is for.

Daniel
CJ/RR 212...under construction  "Pistol Annie"

12many

  • Join Date: Oct 2010
  • Location: indiana
  • *
  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
  • Liked:
  • Likes Given: 0
« Reply #2 on: October 16, 2010, 07:48:22 PM »
i can run 3600 without the secondaries then go to 3800 at wot.seems like i should gain more than 200rpms.

Sanger Pete

  • Join Date: Apr 2008
  • Location: Clovis/Shaver Lake
  • *
  • Full Member
  • ***
  • Posts: 213
  • Karma: +3/-0
    • View Profile
  • Liked:
  • Likes Given: 0
« Reply #3 on: October 17, 2010, 12:12:57 AM »
I would check to make sure the carb is really opening up to full throttle.

12many

  • Join Date: Oct 2010
  • Location: indiana
  • *
  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
  • Liked:
  • Likes Given: 0
« Reply #4 on: October 17, 2010, 08:31:37 AM »
The carb is opening up all the way.The boat is a 21 foot Baro mini daycruser.Very heavy but plains out real fast.i dont need wot to plain it but it feels like it helps when i do.Has anyone heard of a Baro? looks like a splash of a couple ive seen.

jet boat performance

  • Join Date: Dec 2006
  • Location: Atascadero ,California
  • *
  • Informative Member
  • *******
  • Posts: 3,152
  • Karma: +25/-0
    • View Profile
    • jetboatperformance.com
  • Liked:
  • Likes Given: 0
« Reply #5 on: October 17, 2010, 01:55:51 PM »
i can run 3600 without the secondaries then go to 3800 at wot.seems like i should gain more than 200rpms.

A modest "HP" Big block anything  Ford Chevy, Olds etc should turn that jet (with A impeller) somewhere north of 4500 RPMs (depending on altitude) assuming the Tach is correct , your likley looking for fuel supply or other tune-up "issues" always happy to try to help call if we can Tom

12many

  • Join Date: Oct 2010
  • Location: indiana
  • *
  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
  • Liked:
  • Likes Given: 0
« Reply #6 on: October 17, 2010, 04:18:08 PM »
Just put the motor in my new boat today,it also is running an A impeller.Should see what kind of rpm i can get on tuesday.Thanks for all the help. i will let you know the results.

12many

  • Join Date: Oct 2010
  • Location: indiana
  • *
  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
  • Liked:
  • Likes Given: 0
« Reply #7 on: October 19, 2010, 04:37:36 PM »
Took the new boat out today and it only ran 3700 rpm.when i first took off in the boat it just didnt feel like it had as much thrust as i did with the motor in the old boat.I was expecting it to rev out the motor on the top end like the pump was weak.Then when it only hit 3700 its got to be in the motor.Check the carb again today it is opening all the way.Motor sounds great.Didnt even sound like it was struggling today on the top end.Straight HEI dist. doesnt sound like its missfireing.Could the pickup keep it from turning anymore rpms?The new comp cam said it was 4 deg built in so i installed it straight up???

beerjet

  • Join Date: Nov 2006
  • Location: Rancho cucamonga
  • *
  • Team Member
  • Informative Member
  • *******
  • Posts: 9,102
  • Karma: +81/-0
    • View Profile
  • Liked:
  • Likes Given: 22
« Reply #8 on: December 04, 2010, 05:41:14 PM »
They all came with Stainless shafts.
But not with Stainless impellors which is what the "ss" indicates.

Check fuel pressure and ignition.
You never figure it out at idle.

-beerjet-
i dont but im all for stuffin shit in her ass to make her go away :-*

jim brock

  • Join Date: Jul 2007
  • Location: pacoima
  • *
  • Macho Member
  • ******
  • Posts: 2,085
  • Karma: +13/-0
    • View Profile
  • Liked:
  • Likes Given: 1
« Reply #9 on: December 04, 2010, 06:18:31 PM »
If your hei has a vacume advance hooked up, disconnect it, plug the vacume line and time it  at 34-36 degrees total advance.

 


Website Security Test
Powered by EzPortal

Website Security Test