drive cable problems

  • 3 Replies
  • 1166 Views

havasudre

  • Join Date: Dec 2006
  • Location: riverside
  • *
  • Full Member
  • ***
  • Posts: 167
  • Karma: +2/-0
    • View Profile
  • Liked:
  • Likes Given: 0
« on: May 01, 2007, 03:48:43 PM »
after installing my  new motor  and  tons of   other parts         
carb  altanator   fuel pump 
ect
the cable that opens up  my  pumps seens to be  stuck  is there  anything specail about the  install i should know 

putting on the  throttle cable was  really easy so im  hoping  for the same  results


Brad @ SCJB

  • Join Date: Oct 2006
  • Location: Las Vegas, NV
  • *
  • Administrator
  • Informative Member
  • *******
  • Posts: 12,287
  • Karma: +251/-0
  • HNIC
    • View Profile
    • SoCal Jet Boats.com
  • Liked:
  • Likes Given: 116
« Reply #1 on: May 01, 2007, 04:08:27 PM »
make sure theres no kinks in it....pull it out and straighten it out, if it still doesnt budge, it might have rusted while it was out of the boat.
  • Boat #1: 1978 Liberty
  • Boat #2: 1982 Eliminator Sprint

havasudre

  • Join Date: Dec 2006
  • Location: riverside
  • *
  • Full Member
  • ***
  • Posts: 167
  • Karma: +2/-0
    • View Profile
  • Liked:
  • Likes Given: 0
« Reply #2 on: May 02, 2007, 07:38:57 AM »
RIGHTON  COOL  SUNDAY WILL MOST LIKLY  BE THE DAY I TAKE IT  BACK OUT TO THE  LAKE TO  MAKE SURE  EVERTHING  WORKS

Brad @ SCJB

  • Join Date: Oct 2006
  • Location: Las Vegas, NV
  • *
  • Administrator
  • Informative Member
  • *******
  • Posts: 12,287
  • Karma: +251/-0
  • HNIC
    • View Profile
    • SoCal Jet Boats.com
  • Liked:
  • Likes Given: 116
« Reply #3 on: May 02, 2007, 09:51:45 AM »
COOL LIT US NO HOW IT GOSE
  • Boat #1: 1978 Liberty
  • Boat #2: 1982 Eliminator Sprint

 


Website Security Test
Powered by EzPortal

Null

Website Security Test