Place Diverter problem

  • 9 Replies
  • 2898 Views

Diablo

  • Join Date: Mar 2007
  • Location: Ridgecrest
  • *
  • Newbie
  • *
  • Posts: 27
  • Karma: +0/-0
    • View Profile
  • Liked:
  • Likes Given: 0
« on: March 21, 2007, 01:54:16 PM »
Last year my place diverter was working fine, then it stoped working altogehter, I checked the fuse and it was blown so I replaced it and then tried it and it made some noise but then the fuse would blow again.  ??? ???


hotrod56cars

  • Join Date: Nov 2006
  • Location: El Cajon, CA.
  • *
  • Banned
  • Newbie
  • *
  • Posts: 21
  • Karma: +1/-8
    • View Profile
  • Liked:
  • Likes Given: 0
« Reply #1 on: March 21, 2007, 02:19:44 PM »
Sounds like an electrical problem, I've never worked on one so...   ???  I'd have to see it to diagnose it.
Quote
NO REGRET$ ... Arguing on the internet is like competing in the Special Olympics / no matter how good you do you're still retarded!!!!!

                                                          1978  19' Mach 1 Tunnel jet

fast ass ford

  • Join Date: Feb 2007
  • Location: Hemet ca
  • *
  • Sr. Member
  • ****
  • Posts: 265
  • Karma: +3/-0
    • View Profile
  • Liked:
  • Likes Given: 0
« Reply #2 on: March 21, 2007, 03:00:54 PM »
check the switch itself my freinds did the same and the switch was bad it was grounding out hope this helps :)

Ema Non-Performance Marine - BANNED

  • Join Date: Jan 2007
  • Location: Ft. Mohave AZ
  • *
  • Banned
  • Hero Member
  • *****
  • Posts: 1,021
  • Karma: +18/-1
  • BANNED
    • View Profile
  • Liked:
  • Likes Given: 0
« Reply #3 on: March 21, 2007, 04:04:57 PM »
Most likely the Bennet pump is crapping out.
Check everything out first though.

http://www.socaljetboats.com/index.php?topic=328.0
« Last Edit: March 21, 2007, 04:07:07 PM by Emanon Performance Marine »

Diablo

  • Join Date: Mar 2007
  • Location: Ridgecrest
  • *
  • Newbie
  • *
  • Posts: 27
  • Karma: +0/-0
    • View Profile
  • Liked:
  • Likes Given: 0
« Reply #4 on: March 22, 2007, 02:32:41 PM »
Well I checked everything today and looked good when you hit the switch it makes a light sound when you click up or down but nothing happens. The sound is not constant just when you hit the switch.

Ema Non-Performance Marine - BANNED

  • Join Date: Jan 2007
  • Location: Ft. Mohave AZ
  • *
  • Banned
  • Hero Member
  • *****
  • Posts: 1,021
  • Karma: +18/-1
  • BANNED
    • View Profile
  • Liked:
  • Likes Given: 0
« Reply #5 on: March 22, 2007, 02:48:02 PM »
That is because that is the only time the motor has power.

Diablo

  • Join Date: Mar 2007
  • Location: Ridgecrest
  • *
  • Newbie
  • *
  • Posts: 27
  • Karma: +0/-0
    • View Profile
  • Liked:
  • Likes Given: 0
« Reply #6 on: March 22, 2007, 08:30:02 PM »
So does that mean the motor is not working and I need to buy a new Bennett Hydraulic Pump ?

Ema Non-Performance Marine - BANNED

  • Join Date: Jan 2007
  • Location: Ft. Mohave AZ
  • *
  • Banned
  • Hero Member
  • *****
  • Posts: 1,021
  • Karma: +18/-1
  • BANNED
    • View Profile
  • Liked:
  • Likes Given: 0
« Reply #7 on: March 22, 2007, 08:37:46 PM »
Well I would smack the motor with a big mallet and see if it starts working.
I know, I know.............This is what Place does per Lillrick. This will free up the brushes. If it still doesnot work then I have one for you.

Diablo

  • Join Date: Mar 2007
  • Location: Ridgecrest
  • *
  • Newbie
  • *
  • Posts: 27
  • Karma: +0/-0
    • View Profile
  • Liked:
  • Likes Given: 0
« Reply #8 on: March 22, 2007, 09:02:34 PM »
How much?

Ema Non-Performance Marine - BANNED

  • Join Date: Jan 2007
  • Location: Ft. Mohave AZ
  • *
  • Banned
  • Hero Member
  • *****
  • Posts: 1,021
  • Karma: +18/-1
  • BANNED
    • View Profile
  • Liked:
  • Likes Given: 0
« Reply #9 on: March 22, 2007, 09:12:37 PM »

 


Website Security Test
Powered by EzPortal

Website Security Test