Null

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - 82 baja 460

Pages: [1]
1
I'm new to this forum and i have an unstoppable passion for my Jet boat... Currently i have a nasty vibration which i think is coming from the drive shaft which is only 6.5" long (hopefully not the motor).  It doesn't have a PTO on the 460, it's mounted directly to the flywheel/crank shaft.  I've replaced the u joints multiple times and i still have a slight mechanical bind of some sort.  I think the yoke is messed up somehow.  I've replaced the thrust bearing and impeller/sleeve already which didn't help.  I've even removed the bowl and impeller to help trouble shoot and eliminate that part of the drive line. I have the splicer kit 1310 on order with the adapter plate for the 460 bolt pattern, but that makes the drive shaft 2" longer at 8.5" total.  How can i support the rear part of the motor now? it was mounted on the bearing block assembly before.  Also I've had a hard time trying to get the motor mounted at the correct angle.  My understanding is that the engine should be about 1 to 2 degrees off not straight on.  With that said, the oil pan drain plug area hits the bottom of the boat.  I've had this boat for about 1.5 years now and I've replaced the stringers, floor and interior last winter.  It ran great for the first month then i noticed a slight vibration which turned really bad really quick.  Any guidance would be appreciated thanks. (Ford 460 big block with a Berkeley 12JE)

Pages: [1]

Null

SMFPacks CMS 1.0.3 © 2020